We don't recognise this app - Error while authorising my app


I have an issue where an app I wrote that has been working fine has
suddenly stopped working the the error after I log in to FreeAgent while
trying to authorize the app:

Sorry, there’s been a problem.

We don’t recognise this app. Please get in touch with the author of the
application you’re trying to approve.
The I’ve tried re-generating the tokens and putting the new tokens in my
app but to no avail. I’ve also tried authenticating using the google OAuth
sandbox and get the same error.

My app is called FATT (https://dev.freeagent.com/apps/1389) and the (new)
OAuth Id is: TzcqWgPMA0Vsonbt1JU3jQ


Hi Sam,

We pushed out a release earlier that broke API Approval in a subtle manner which we didn’t catch beforehand. I’ve just released a fix for it (and added regression tests around the subtle change to prevent us missing it in future.) so you should be able to approve your API Application properly now.

Sorry about that, and please get back in touch if it’s still not working for you.

Caius Durling
Engineer, FreeAgent

One Edinburgh Quay, 133 Fountainbridge, Edinburgh, EH3 9QG
FreeAgent Central Ltd. Registered in sunny Scotland SC316774