The redirect URI is invalid for this app


#1

Hello all,

suddenly my report feature has stopped working without having changed anything.

http://www.ecomize.com/reports/expenses.php?year=2014&month=12&user=

After approving my application i get following error message.

"
Sorry, there’s been a problem

The redirect URI is invalid for this app. Please get in touch with the author of the application you’re trying to approve.
"

I found some threads about HTTP/S and enabled thereafter HTTPS to make sure, that this is not the issue… but still getting the same error using

https://www.ecomize.com/reports/expenses.php?year=2014&month=12&user=

Does anyone have any idea what is gong on recently?

Regards,

Andreas


#2

I think i am better understand the issue. FreeAgent introduced since February 2017 the “Redirect URI” parameter, but i assume the logic is buggy

When i open my application with following URL

https://www.ecomize.com:443/reports/expenses.php

Then FreeAgent tries to redirect after approval to https://www.ecomize.com:443/reports/expenses.php&response_type=code

The parameter “response_type” is append to the URL from FreeAgent and makes my URL invalid

using the URL with parameters generates

http://www.ecomize.com:443/reports/expenses.php?year=2014&month=12&user=

results after approval into

http://www.ecomize.com:443/reports/expenses.php?year=2014&month=12&user=XYZ&response_type=code

I tried to get around that by using for “Redirect URI” settings

https://.ecomize.com//expenses.php
http://.ecomize.com//expenses.php
https://.ecomize.com:443//expenses.php

but nothing works so far, any suggestions?


#3

Hi Andreas

I think you may be experiencing the same issue that we are (see: Potential issue with app approvals in FreeAgent production (works in sandbox)).

FreeAgent can’t seem to handle query strings in the redirect_uri very well. If you need to pass parameters around, you might want to consider hex-encoding them into a single value, i.e. expenses.php?<hex-encoded-query-string>.


#4

Hi,

i kind of solved the issue by always sending the same hard-coded redirect url e.g.

https://www.ecomize.com:443/reports/expenses.php

without any query string. I believe the introduced “Redirect URI” setting is not working so well when a query string is attached. That is very sad! Hopefully they can fix it someday