HTTP Basic: Access denied


I have a application running for a while to create financial reports from the FreeAgent data.
It was working fine but suddenly I am getting 403 errors.
I registered a new app and updated the id and secret in my application but now the Oauth authentication is not working anymore while it was working before.

After authentication I get ‘code’ back and I am doing a post call to the /v2/token_endpoint.
No matter what I do I get a 401 unauthorized with body HTTP Basic: Access denied.

I am reading about firewall changes and that this issue should be resolved but it doesn’t seem that way. I tried to do the call through the app and through a simple postman call but both are giving the same result.

Your help is much appreciated.

With kind regards,

Not sure if something changed but it seems the /v2/token_endpoint is not giving the basic authentication error anymore. My application is succesfully authenticating again. Maybe it has something to do with firewall changes but it seems to work again.