Creating Task

try /v2/projects/407234 in the URL

and possibly put in a unit and hourly/daily rate (even if it’s 0).On 3 June 2013 06:13, Andy Jones support@pipethru.com wrote:

I’m having trouble creating a new task - I keep getting the error “Resource
not found”

I keep POSTing to the URL

https://api.freeagent.com/v2/tasks?project=https://api.freeagent.com/v2/projects/407234

with the data…

{“task”:{“name”:“Test Task”,“status”:“Active”}}

But alas, no joy. I’ve tried many permutations…

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

https://api.freeagent.com/v2/tasks?project_id=407234

with many permutations of the JSON encoded data as well. Its not clear to me
in the documentation what I’m doing wrong. Is this a bug in the API or am I
missing some key parameter?


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to freeagent_api+unsubscribe@googlegroups.com.
To post to this group, send email to freeagent_api@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/

I was using a cached version of the project which no longer existed. The
“Resource not found” was referring to the project even though I was trying
to create a task.On Monday, June 3, 2013 11:05:46 AM UTC-4, Andy Jones wrote:

As yes - I’ve been testing so much I forgot to wrap the object…

{“task”:{“name”:“Test
Task”,“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}}

So I did that and still got the same “Resource not found” error message -
but then I looked at the project…

I changed the project id to a different project that I knew existed and
successful response on the GET tasks - I’ll look into where my project is
coming from.

Thanks for the help!

On Monday, June 3, 2013 10:55:09 AM UTC-4, Nic Wise wrote:

Thank you for your response. I just tried posting to

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

with the data

{“name”:"Test

Task",“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}

and I received the same result

{“errors”:{“error”:{“message”:“Resource not found”}}}

Is this a bug in the API? I’m doing this against the live version - NOT
sandbox.

That looks very much like what I’m posting. I assume that project
exists and is active?

don’t forget the { “task”: {…}} infront.

On Monday, June 3, 2013 5:21:11 AM UTC-4, Nic Wise wrote:

try /v2/projects/407234 in the URL

and possibly put in a unit and hourly/daily rate (even if it’s 0).

On 3 June 2013 06:13, Andy Jones sup...@pipethru.com wrote:

I’m having trouble creating a new task - I keep getting the error
“Resource
not found”

I keep POSTing to the URL

https://api.freeagent.com/v2/tasks?project=https://api.freeagent.com/v2/projects/407234

with the data…

{“task”:{“name”:“Test Task”,“status”:“Active”}}

But alas, no joy. I’ve tried many permutations…

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

https://api.freeagent.com/v2/tasks?project_id=407234

with many permutations of the JSON encoded data as well. Its not
clear

to me
in the documentation what I’m doing wrong. Is this a bug in the API
or

am I
missing some key parameter?


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it,
send

an
email to freeagent_ap...@googlegroups.com.
To post to this group, send email to freeag...@googlegroups.com.
Visit this group at
http://groups.google.com/group/freeagent_api?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to freeagent_ap...@googlegroups.com.
To post to this group, send email to freeag...@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/

Thank you for your response. I just tried posting to

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

with the data

{“name”:“Test
Task”,“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}

and I received the same result

{“errors”:{“error”:{“message”:“Resource not found”}}}

Is this a bug in the API? I’m doing this against the live version - NOT
sandbox.

That looks very much like what I’m posting. I assume that project
exists and is active?

don’t forget the { “task”: {…}} infront.

try /v2/projects/407234 in the URL

and possibly put in a unit and hourly/daily rate (even if it’s 0).

I’m having trouble creating a new task - I keep getting the error
“Resource
not found”

I keep POSTing to the URL

https://api.freeagent.com/v2/tasks?project=https://api.freeagent.com/v2/projects/407234

with the data…

{“task”:{“name”:“Test Task”,“status”:“Active”}}

But alas, no joy. I’ve tried many permutations…

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

https://api.freeagent.com/v2/tasks?project_id=407234

with many permutations of the JSON encoded data as well. Its not clear
to me
in the documentation what I’m doing wrong. Is this a bug in the API or
am I
missing some key parameter?


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to freeagent_ap...@googlegroups.com.
To post to this group, send email to freeag...@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to freeagent_api+unsubscribe@googlegroups.com.
To post to this group, send email to freeagent_api@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/

Thank you for your response. I just tried posting to

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

with the data

{“name”:“Test
Task”,“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}

and I received the same result

{“errors”:{“error”:{“message”:“Resource not found”}}}

Is this a bug in the API? I’m doing this against the live version - NOT
sandbox.On Monday, June 3, 2013 5:21:11 AM UTC-4, Nic Wise wrote:

try /v2/projects/407234 in the URL

and possibly put in a unit and hourly/daily rate (even if it’s 0).

On 3 June 2013 06:13, Andy Jones <sup...@pipethru.com <javascript:>> wrote:

I’m having trouble creating a new task - I keep getting the error
“Resource
not found”

I keep POSTing to the URL

https://api.freeagent.com/v2/tasks?project=https://api.freeagent.com/v2/projects/407234

with the data…

{“task”:{“name”:“Test Task”,“status”:“Active”}}

But alas, no joy. I’ve tried many permutations…

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

https://api.freeagent.com/v2/tasks?project_id=407234

with many permutations of the JSON encoded data as well. Its not clear
to me
in the documentation what I’m doing wrong. Is this a bug in the API or
am I
missing some key parameter?


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to freeagent_ap...@googlegroups.com <javascript:>.
To post to this group, send email to freeag...@googlegroups.com<javascript:>.

Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/

As yes - I’ve been testing so much I forgot to wrap the object…

{“task”:{“name”:“Test
Task”,“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}}

So I did that and still got the same “Resource not found” error message -
but then I looked at the project…

I changed the project id to a different project that I knew existed and
successful response on the GET tasks - I’ll look into where my project is
coming from.

Thanks for the help!On Monday, June 3, 2013 10:55:09 AM UTC-4, Nic Wise wrote:

Thank you for your response. I just tried posting to

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

with the data

{“name”:"Test

Task",“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}

and I received the same result

{“errors”:{“error”:{“message”:“Resource not found”}}}

Is this a bug in the API? I’m doing this against the live version - NOT
sandbox.

That looks very much like what I’m posting. I assume that project
exists and is active?

don’t forget the { “task”: {…}} infront.

On Monday, June 3, 2013 5:21:11 AM UTC-4, Nic Wise wrote:

try /v2/projects/407234 in the URL

and possibly put in a unit and hourly/daily rate (even if it’s 0).

On 3 June 2013 06:13, Andy Jones sup...@pipethru.com wrote:

I’m having trouble creating a new task - I keep getting the error
“Resource
not found”

I keep POSTing to the URL

https://api.freeagent.com/v2/tasks?project=https://api.freeagent.com/v2/projects/407234

with the data…

{“task”:{“name”:“Test Task”,“status”:“Active”}}

But alas, no joy. I’ve tried many permutations…

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

https://api.freeagent.com/v2/tasks?project_id=407234

with many permutations of the JSON encoded data as well. Its not
clear

to me
in the documentation what I’m doing wrong. Is this a bug in the API
or

am I
missing some key parameter?


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it,
send

an
email to freeagent_ap...@googlegroups.com.
To post to this group, send email to freeag...@googlegroups.com.
Visit this group at
http://groups.google.com/group/freeagent_api?hl=en.

For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to freeagent_ap...@googlegroups.com <javascript:>.
To post to this group, send email to freeag...@googlegroups.com<javascript:>.

Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/

Excellent, glad it’s working for you now :)On 3 June 2013 16:25, Andy Jones support@pipethru.com wrote:

I was using a cached version of the project which no longer existed. The
“Resource not found” was referring to the project even though I was trying
to create a task.

On Monday, June 3, 2013 11:05:46 AM UTC-4, Andy Jones wrote:

As yes - I’ve been testing so much I forgot to wrap the object…

{“task”:{“name”:“Test
Task”,“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}}

So I did that and still got the same “Resource not found” error message -
but then I looked at the project…

I changed the project id to a different project that I knew existed and
successful response on the GET tasks - I’ll look into where my project is
coming from.

Thanks for the help!

On Monday, June 3, 2013 10:55:09 AM UTC-4, Nic Wise wrote:

Thank you for your response. I just tried posting to

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

with the data

{“name”:"Test

Task",“is_billable”:true,“billing_rate”:“0.0”,“billing_period”:“hour”,“status”:“Active”}

and I received the same result

{“errors”:{“error”:{“message”:“Resource not found”}}}

Is this a bug in the API? I’m doing this against the live version - NOT
sandbox.

That looks very much like what I’m posting. I assume that project
exists and is active?

don’t forget the { “task”: {…}} infront.

On Monday, June 3, 2013 5:21:11 AM UTC-4, Nic Wise wrote:

try /v2/projects/407234 in the URL

and possibly put in a unit and hourly/daily rate (even if it’s 0).

On 3 June 2013 06:13, Andy Jones sup...@pipethru.com wrote:

I’m having trouble creating a new task - I keep getting the error
“Resource
not found”

I keep POSTing to the URL

https://api.freeagent.com/v2/tasks?project=https://api.freeagent.com/v2/projects/407234

with the data…

{“task”:{“name”:“Test Task”,“status”:“Active”}}

But alas, no joy. I’ve tried many permutations…

https://api.freeagent.com/v2/tasks?project=/v2/projects/407234

https://api.freeagent.com/v2/tasks?project_id=407234

with many permutations of the JSON encoded data as well. Its not
clear
to me
in the documentation what I’m doing wrong. Is this a bug in the API
or
am I
missing some key parameter?


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it,
send
an
email to freeagent_ap...@googlegroups.com.
To post to this group, send email to freeag...@googlegroups.com.
Visit this group at
http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/


You received this message because you are subscribed to the Google
Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to freeagent_ap...@googlegroups.com.
To post to this group, send email to freeag...@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to freeagent_api+unsubscribe@googlegroups.com.
To post to this group, send email to freeagent_api@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Nic Wise
t. +44 7788 592 806 | @fastchicken
b. http://www.fastchicken.co.nz/