Approve_app problem

Hi,
I receive the following error when I try to get to the approve_app
endpoint
(https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA):
Format not recognised. Set accept http header to application/json or
application/xml

I don’t think the accept header should be necessary for this particular
URL (I don’t see how to set it in the client browser but that is another
matter).

Any help will be much appreciated.

Regards,
Hristo

Hi Graeme,

I suppose I’m becoming a pain in the neck but now I get a different error.
I changed my email as you suggested - thank you for that - but now I
receive:
“Sorry, there’s been a problem.
Please get in touch with the author of the application you’re trying to
authorise.”
when I submit the login form for the authorization.

I tried removing the port number from the callback URI (there are some
services that don’t allow it) but the result is the same.
I tried both generating the URL myself and using Google Oauth Playground
but the results are the same.

I’m not sure whether I’m doing something wrong or there is something
wrong with my account.

Regards,
HristoOn 16.3.2012 г. 14:45 ч., Graeme Boyd wrote:

Hi Hristo,

Your email address is associated with two companies which is why login
at OAuth is not working. Unfortunately at the moment OAuth only works
where the email address is unique. Can you change the email address
so that your user in each company has a different email address?

Cheers,

Graeme

On 16 March 2012 11:35, Hristo Dokov <hdokov@gmail.com mailto:hdokov@gmail.com> wrote:

Hi Graeme,
The URL with 'v2' works fine but when I try to log in i receive
the following error: Email or password not recognised.
Bu I use the same credentials on
https://rbtest.sandbox.freeagent.com/login and they work fine.

Am I missing something - I tried several times using different
browsers and the result is the same.

Regards,
Hristo


On 15.3.2012 г. 12:45 ч., Graeme Boyd wrote:
Hi Hristo,

I just realised that the docs on the OAuth page were wrong.  I've
updated them to add the /v2 back in.

Sorry about that.

Graeme

On 15 March 2012 10:38, Graeme Boyd <graeme.boyd@freeagent.com <mailto:graeme.boyd@freeagent.com>> wrote:

    Hi Hristo,

    Your url is slightly wrong, the /v2 is missing:

    https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
    <https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA>

    Kind regards,

    Graeme


    On 15 March 2012 10:30, Hristo Dokov <hdokov@gmail.com <mailto:hdokov@gmail.com>> wrote:

        Hi,
        I receive the following error when I try to get to the
        approve_app endpoint
        (https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
        <https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA>):
        Format not recognised.  Set accept http header to
        application/json or application/xml

        I don't think the accept header should be necessary for
        this particular URL (I don't see how to set it in the
        client browser but that is another matter).

        Any help will be much appreciated.

        Regards,
        Hristo

        -- 
        You received this message because you are subscribed to
        the Google Groups "FreeAgent API" group.
        To post to this group, send email to
        freeagent_api@googlegroups.com
        <mailto:freeagent_api@googlegroups.com>.
        To unsubscribe from this group, send email to
        freeagent_api+unsubscribe@googlegroups.com
        <mailto:freeagent_api%2Bunsubscribe@googlegroups.com>.
        For more options, visit this group at
        http://groups.google.com/group/freeagent_api?hl=en.




    -- 
    Graeme Boyd
    Senior Software Engineer
    FreeAgent Central Ltd
    40 Torphichen Street, Edinburgh EH3 8JB
    Registered in Scotland SC316774




-- 
Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774
-- 
You received this message because you are subscribed to the
Google Groups "FreeAgent API" group.
To post to this group, send email to
freeagent_api@googlegroups.com
<mailto:freeagent_api@googlegroups.com>.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com
<mailto:freeagent_api+unsubscribe@googlegroups.com>.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.
-- 
You received this message because you are subscribed to the Google
Groups "FreeAgent API" group.
To post to this group, send email to
freeagent_api@googlegroups.com
<mailto:freeagent_api@googlegroups.com>.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com
<mailto:freeagent_api%2Bunsubscribe@googlegroups.com>.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.


Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

You received this message because you are subscribed to the Google
Groups “FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.

Hi Graeme,
The URL with ‘v2’ works fine but when I try to log in i receive the
following error: Email or password not recognised.
Bu I use the same credentials on
https://rbtest.sandbox.freeagent.com/login and they work fine.

Am I missing something - I tried several times using different browsers
and the result is the same.

Regards,
HristoOn 15.3.2012 ?. 12:45 ?., Graeme Boyd wrote:

Hi Hristo,

I just realised that the docs on the OAuth page were wrong. I’ve
updated them to add the /v2 back in.

Sorry about that.

Graeme

On 15 March 2012 10:38, Graeme Boyd <graeme.boyd@freeagent.com mailto:graeme.boyd@freeagent.com> wrote:

Hi Hristo,

Your url is slightly wrong, the /v2 is missing:

https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
<https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA>

Kind regards,

Graeme


On 15 March 2012 10:30, Hristo Dokov <hdokov@gmail.com <mailto:hdokov@gmail.com>> wrote:

    Hi,
    I receive the following error when I try to get to the
    approve_app endpoint
    (https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
    <https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA>):
    Format not recognised.  Set accept http header to
    application/json or application/xml

    I don't think the accept header should be necessary for this
    particular URL (I don't see how to set it in the client
    browser but that is another matter).

    Any help will be much appreciated.

    Regards,
    Hristo

    -- 
    You received this message because you are subscribed to the
    Google Groups "FreeAgent API" group.
    To post to this group, send email to
    freeagent_api@googlegroups.com
    <mailto:freeagent_api@googlegroups.com>.
    To unsubscribe from this group, send email to
    freeagent_api+unsubscribe@googlegroups.com
    <mailto:freeagent_api%2Bunsubscribe@googlegroups.com>.
    For more options, visit this group at
    http://groups.google.com/group/freeagent_api?hl=en.




-- 
Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774


Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

You received this message because you are subscribed to the Google
Groups “FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.

Hi Hristo,

I just realised that the docs on the OAuth page were wrong. I’ve updated
them to add the /v2 back in.

Sorry about that.

GraemeOn 15 March 2012 10:38, Graeme Boyd graeme.boyd@freeagent.com wrote:

Hi Hristo,

Your url is slightly wrong, the /v2 is missing:

https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA

Kind regards,

Graeme

On 15 March 2012 10:30, Hristo Dokov hdokov@gmail.com wrote:

Hi,
I receive the following error when I try to get to the approve_app
endpoint (https://api.sandbox.freeagent.com/approve_app?
response_type=code&client_id=**L7S5UDVN5Qml2k_l6XVjSAhttps://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
):
Format not recognised. Set accept http header to application/json or
application/xml

I don’t think the accept header should be necessary for this particular
URL (I don’t see how to set it in the client browser but that is another
matter).

Any help will be much appreciated.

Regards,
Hristo


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com**.
To unsubscribe from this group, send email to freeagent_api+unsubscribe@*
googlegroups.com freeagent_api%2Bunsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/
*
group/freeagent_api?hl=enhttp://groups.google.com/group/freeagent_api?hl=en
.


Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

Hi Hristo,

Your email address is associated with two companies which is why login at
OAuth is not working. Unfortunately at the moment OAuth only works where
the email address is unique. Can you change the email address so that your
user in each company has a different email address?

Cheers,

GraemeOn 16 March 2012 11:35, Hristo Dokov hdokov@gmail.com wrote:

Hi Graeme,
The URL with ‘v2’ works fine but when I try to log in i receive the
following error: Email or password not recognised.
Bu I use the same credentials on
https://rbtest.sandbox.freeagent.com/login and they work fine.

Am I missing something - I tried several times using different browsers
and the result is the same.

Regards,
Hristo

On 15.3.2012 г. 12:45 ч., Graeme Boyd wrote:

Hi Hristo,

I just realised that the docs on the OAuth page were wrong. I’ve
updated them to add the /v2 back in.

Sorry about that.

Graeme

On 15 March 2012 10:38, Graeme Boyd graeme.boyd@freeagent.com wrote:

Hi Hristo,

Your url is slightly wrong, the /v2 is missing:

https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA

Kind regards,

Graeme

On 15 March 2012 10:30, Hristo Dokov hdokov@gmail.com wrote:

Hi,
I receive the following error when I try to get to the approve_app
endpoint (
https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
):
Format not recognised. Set accept http header to application/json or
application/xml

I don’t think the accept header should be necessary for this particular
URL (I don’t see how to set it in the client browser but that is another
matter).

Any help will be much appreciated.

Regards,
Hristo


You received this message because you are subscribed to the Google
Groups “FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.


Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774


Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.

Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

Hi Hristo,

Your url is slightly wrong, the /v2 is missing:

https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA

Kind regards,

GraemeOn 15 March 2012 10:30, Hristo Dokov hdokov@gmail.com wrote:

Hi,
I receive the following error when I try to get to the approve_app
endpoint (https://api.sandbox.freeagent.com/approve_app?
response_type=code&client_id=**L7S5UDVN5Qml2k_l6XVjSAhttps://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
):
Format not recognised. Set accept http header to application/json or
application/xml

I don’t think the accept header should be necessary for this particular
URL (I don’t see how to set it in the client browser but that is another
matter).

Any help will be much appreciated.

Regards,
Hristo


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com**.
To unsubscribe from this group, send email to freeagent_api+unsubscribe@**
googlegroups.com freeagent_api%2Bunsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/**
group/freeagent_api?hl=enhttp://groups.google.com/group/freeagent_api?hl=en
.

Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

Hi Graeme,
Thanks for the help.
The thing is the ‘/v2’ part is not included in the online documentation
and I obviously missed the discussion about it.

Thanks again,
HristoOn 15.3.2012 ?. 12:38 ?., Graeme Boyd wrote:

Hi Hristo,

Your url is slightly wrong, the /v2 is missing:

https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
https://api.sandbox.freeagent.com/v2/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA

Kind regards,

Graeme

On 15 March 2012 10:30, Hristo Dokov <hdokov@gmail.com mailto:hdokov@gmail.com> wrote:

Hi,
I receive the following error when I try to get to the approve_app
endpoint
(https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA
<https://api.sandbox.freeagent.com/approve_app?response_type=code&client_id=L7S5UDVN5Qml2k_l6XVjSA>):
Format not recognised.  Set accept http header to application/json
or application/xml

I don't think the accept header should be necessary for this
particular URL (I don't see how to set it in the client browser
but that is another matter).

Any help will be much appreciated.

Regards,
Hristo

-- 
You received this message because you are subscribed to the Google
Groups "FreeAgent API" group.
To post to this group, send email to
freeagent_api@googlegroups.com
<mailto:freeagent_api@googlegroups.com>.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com
<mailto:freeagent_api%2Bunsubscribe@googlegroups.com>.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.


Graeme Boyd
Senior Software Engineer
FreeAgent Central Ltd
40 Torphichen Street, Edinburgh EH3 8JB
Registered in Scotland SC316774

You received this message because you are subscribed to the Google
Groups “FreeAgent API” group.
To post to this group, send email to freeagent_api@googlegroups.com.
To unsubscribe from this group, send email to
freeagent_api+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/freeagent_api?hl=en.