App authentication redirect URI containing space won't work

Hi Stas,

The redirect URL must be urlencoded
http://www.w3schools.com/tags/ref_urlencode.asp. If you would like to pass
a space in the address you should pass it like this:

http://localhost:9000/dashboards/FreeAgentCompany%20Test/Finance

Where %25 encodes a percent sign. This will allow you to have spaces in
your URLs.

Sorry you’ve not had a reply to your question sooner.

Kind regards,

GraemeOn 4 April 2013 08:27, stas stanislav.semakin@smeebi.com wrote:

Hi guys,

We’ve run into a technical issue. In a nutshell, if the redirect URI
contains space the user is not authenticated (redirected back to our app)
via FreeAgent API. Example of a valid URI which won’t work:

http://localhost/**dashboards/FreeAgentCompany%**20Test/Financehttp://localhost:9000/dashboards/FreeAgentCompany%20Test/Finance

In this case we are redirected to freeagent.com.

Could you guys confirm the issue or is it a deliberate restriction?

Thanks,
Stas


You received this message because you are subscribed to the Google Groups
“FreeAgent API” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to freeagent_api+unsubscribe@googlegroups.com.
To post to this group, send email to freeagent_api@googlegroups.com.
Visit this group at http://groups.google.com/group/freeagent_api?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Graeme Boyd
Senior Software Engineer

Web. freeagent.com http://www.freeagent.com/ Blog. freeagent.com/blog
Twitter. @freeagent https://twitter.com/#!/freeagent Facebook.
facebook.com/freeagentapp

40 Torphichen Street, Edinburgh, EH3 8JB
FreeAgent Central Ltd. Registered in sunny Scotland SC316774