500 error on bank transactions endpoint


#1

Hello!

I am getting 500 errors on the bank transactions endpoint when I don’t use the updated_since query parameter.

This fails:

curl -I \
-H "Authorization: Bearer MYTOKEN" \
-H "Accept: application/json" \
-H "Content-Type: application/json" \
"https://api.sandbox.freeagent.com/v2/bank_transactions?bank_account=https%3A%2F%2Fapi.sandbox.freeagent.com%2Fv2%2Fbank_accounts%2F1234"

This succeeds:

curl -I \
-H "Authorization: Bearer MYTOKEN" \
-H "Accept: application/json" \
-H "Content-Type: application/json" \
"https://api.sandbox.freeagent.com/v2/bank_transactions?bank_account=https%3A%2F%2Fapi.sandbox.freeagent.com%2Fv2%2Fbank_accounts%2F1234&updated_since=2019-01-07T13%3A47%3A01.218Z"

According to the documentation the updated_since parameter is optional.

Please could you help me?

Many thanks in advance,

Andrew Stewart


https://doubleagent.io


#2

I should add this is in the sandbox. Production is ok.


#3

Furthermore an updated_since of 1 year ago works but 2 years ago fails.


#4

Hi Andrew,

Just a quick message to let you know that we’ll be looking into this for you today. Thanks for your patience and we’ll be back in touch again shortly.

Kind regards,
Dave J


#5

Hi Andrew,

OK, after searching through the logs I was able to locate your requests that were triggering the 500 error. Digging a little deeper, it looks like we were having trouble fetching the attachment for one of your dummy bank_account_entries, which probably stems from a recent update we’ve made on how files are handled internally.

I think I’ve fixed everything up now and you should be able to enumerate your transactions once again. Let me know if you have any further problems and thanks again for your patience!

Cheers,
Dave J


#6

Hi Dave,

Thank you very much! I can confirm it’s working for me now.

I appreciate the speedy help :slight_smile:

Yours,
Andrew